Jump to content
Gregamir

Radio unit problem (RNS 310)

Recommended Posts

Hey there guys,

So today I was driving as usual, and I noticed that the name of the track that was playing from the memory card wasnt displyed on screen, so I tried to tap "back" and it wouldnt respond. I stopped on a bus stop to shut the car down and I was hoping thats gonna "restart" the radio unit, but it was like radio reset itself, then it was just stuck on "welcome to volkswagen" logo and still is. 
Funny thing is that I have full control over the radio unit on steering wheel buttons (like next track, previous track, volume, etc.), but the touch screen just doesnt react at all o.O I tried the 3 button reset, doesnt respond at all, unplugged the cars battery hoping that it will reset itself the hard way, but it just freezes on welcome logo. If I press "RADIO" tab on the side it DOES switch to radio and the sound is playing and if I press "MEDIA" it also DOES switch back to SD card and the sound is also playing, but for reason the screen is just frozen in time lol. I took some pictures.. 

Im also wondering where is the damn "reset pin hole on the back of the unit" everyone keeps talking about on the internet o.O

Ive read a few posts here and there, for some people its as easy as pressing the 3 way magical combo haha, but it wont work for me no matter what I do. Im a little lost and also affraid, because the car isnt really under warranty anymore :S and those RNS 510 units also arent really cheap to replace :S

Now before you judge me and tell me that the unit is outdated anyway, I know. But at the moment I cant just throw money at the dealer to replace this one, so Im looking for some sort of advice on how to possibly fix this before I spend money on it.

Thank you guys so much! I appreciate every bit of information you can give! :)

Kind regards
-Greg

111.jpg

22.jpg

Share this post


Link to post
Share on other sites

Hi Greg, it's been a while but I used to have an RNS510 in my Seat Leon, I dont think there is any other way of doing a reset than via the button presses you mention I'm afraid. You could try an update but I'm not sure if you need the screen to do that? Unfortunately you may have to take the car either to VW or probably best to a VAG specialist to see if there is anything they can do.
Good luck getting it sorted, sorry I cant be of more help.

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, SpursMadDave said:

Hi Greg, it's been a while but I used to have an RNS510 in my Seat Leon, I dont think there is any other way of doing a reset than via the button presses you mention I'm afraid. You could try an update but I'm not sure if you need the screen to do that? Unfortunately you may have to take the car either to VW or probably best to a VAG specialist to see if there is anything they can do.
Good luck getting it sorted, sorry I cant be of more help.

Sent from my SM-G950F using Tapatalk
 

Hey man, thanks a lot! Im just wondering, are talking about 3 buttons on the front or is there another one on the back that Im missing out?

Share this post


Link to post
Share on other sites
Hey man, thanks a lot! Im just wondering, are talking about 3 buttons on the front or is there another one on the back that Im missing out?
Doesn't look like it from your pic, while you have it out check all the connections and wires for any obvious damage bit I have a feeling it is something failed in the unit unfortunately... the fact that everything is working but the screen not responding makes me think that but best to get an expert to look at it.

Try these guys https://vw-retrofit.co.uk/

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Current Donation Goals

  • Recently Browsing   0 members

  • Similar Content

    • By ALS391
      So Friday morning no sound coming from radio,
      phone, media & Satnav all ok
      then I realised it wasn't changing channel as well
      changed band which worked but still no sound
      switched off / on and left for a few minutes, no change
      When I got home rang my local VW Inchcape Stockport garage, LoL, they need car for a day for diagnostics and next available appointment 10 days !
      that is very disappointing and hope I've not got stuck with hopeless service after being spoilt by MB.
      Checked internet and found the service menu (hold menu button till it changes) and went to find the reset option couldn't find this but after just doing this it's all working as it should, cross fingers.
      Has anyone had this kind of issue ?
      Does anyone know how to ' reset ' properly just in case for next time
       
    • By vw1961
      hi, i attend my new car....
       
      you have any infos and photo of the radio that i have inside the  Composition  8''  ?
       
      its true i see the photos labels of the all radio stations or not ?
       
       
      i see (at colours) the photos of the folder of the mp3 music songs ?
       
       
      PS indooor i have yes or not the  CD player ? the music is charger by SD card ?
       
       
       
      thkans  :-)
    • By Stubsy
      To have one of your mates from school on national radio, but it happens. My mate Ivan Gonzalez of max and Ivan has managed to get a show on BBC radio 4
       
      http://www.bbc.co.uk/programmes/b05pnsr2
       
      They also won a fosters award at the Edinburgh fringe festival for their wrestling show (worth a youtube).
       
      Thought I'd share so you lot can enjoy
×
×
  • Create New...