Jump to content

MK7 full LED tail lights dynamic coding fault


Recommended Posts

Hello,

 

I have a golf 7 2017 europe  halogen rear light and I switched to dynamic tail led lights. I have a problem when I put my lights on position 0 the dynamic lights doesn't work. They only activate on the position lights. i Think i have some problem on coding does anyone know how to solve this problem on which Leuchte ?

 

Thanks

Link to post
Share on other sites
  • Replies 9
  • Created
  • Last Reply

Top Posters In This Topic

@MLR: Alas, there's  NO one-size-fits-all answer to your question. It depends on lots of factors and most importantly, your exercise is non-OEM  - meaning that there is no VW factory equivalent to your new tails.

 

If your car was delivered with incandescent tails, it would have been built with a wiring loom that had an insufficient number of wires for the new LED fittings

 

The way that non-OEM light-fitting manufacturers deal with this is to use a cross wiring harness . These harnesses vary with different manufacturers

 

So, bottom line = we need to know much more about your specific equipment and it would help if you shared the code-change instructions from the manufacturer of the new tails

 

Don

Link to post
Share on other sites

@dv52 Thank you for your feedback. My new tails led are OEM Ref: 5G0945207G; 5G0945208G; 5G0945307P; 5G0945308P

I added a Plug and play wiring kit for the Golf Mk7 to convert from halogen tail lights to LED tail lights.. This is my coding :

IMG-0103.pngIMG-0102.pngIMG-0101.pngIMG-0100.pngIMG-0099.png

IMG-0098.png

 

The only problem i have when i'am on the position 0  my dynamic  turn lights doesn't work  they work like normal. When i put it to low beam they work. I think it's a coding problem.

MLR


 

 

Link to post
Share on other sites

hmm......... no, those Leuchte-sets don't help.

 

For example, Leuchte17TFL R BLK SRB3TFL R BLK SR KC3 normally controls the Turn Signal, rear right inside lamp on factory fitted  LED taillights.

Your car was factory fitted with incandescent tails - so the pin on the central electrics module that is operated by this Leuchte-set doesn't have a connected wire. Hence there is no point programming this Leuchte-set

 

The wiring harness breaks the OEM factory assignment of Leuchte-sets to lamps. So each different harness manufacturer forces a different assignment.  I've never seen a "Plug-and-Play" wiring harness - although every manufacturer says theirs is P&P!

 

Look through your tail light Leuchte-sets and post-up any that have Blinken links/rechts Hellphase Leuchte-command (and i need to see ALL 19 x channels for each Leuchte-set)

 

Maybe put all the data in one file and attach to a post - do you have a copy of the coding instructions from the manufacturer too)

 

Don

Link to post
Share on other sites

 I tried  with this configuration unfortunately does't  work. I also noticed when my car is OFF and  when I turn on the right or left turn signal the position lights turn on example if i turn on the right turn signal then the right position light go ON.

If you have any idea to help me with this problem.

 

Many thanks

Link to post
Share on other sites

@MLR: yes, that particular light-function was programmed into Leuchte23SL HLC10 and Leuchte24SL HRA65 with your new coding. It's called "Single Side Parking Light" (SSPL) - look in your owner's manual. SSPL is meant as a safety feature that indicates the car's position on one side in dark evenings when the ignition is off and the car is locked (just one LED illuminates- so minimal battery drain)

 

Not sure what's happening with your turn signals - are there any error codes? Did the wiring instructions say that the dynamic turn signals require a separate voltage supply ?

 

Don
 

Link to post
Share on other sites

Thank you Don,  i don't have any errors on my OBD and the dynamic turn signals work only the the position lights for the  position 0 they work normal led turn signals. I don't know why i followed all step on the manual of coding. i changed everything you said without result unfortunately 

Link to post
Share on other sites

yes, all very mysterious indeed - as I said, these type of installations are very non-OEM meaning that each manufacturer uses a different circuit for their products.

 

If you are certain that the harness is compatible with the new tails AND that the wiring is EXACTLY as per the manufacturer's specs - then my only remaining suggestion is to grab a multi-meter and check voltages on the turn signal pins.

 

Again with the caveat that this is a third-party product, the arrangement for some manufacturers is that the dynamic turn-signal function needs 2 x separate supplies; a signal ON/OFF pulse to make the lamp blink and a separate +12volt supply to energize the LED chaser circuit inside the fitting. These tail lights need a separate Leuchte-set for each function, or they need a separate wire to be connected to a +12volt supply

 

The alternative  arrangement for other tail-light manufacturers is to use the ON/OFF signal for both purposes.

 

I have confirmed that the Leuchte-sets for the ON/OFF signal on your car is correctly programmed. But I have no idea how the internal LED chaser circuits are energized on your tails.

 

Don

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Current Donation Goals

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...